lkml.org 
[lkml]   [2008]   [Jul]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [Bug #10872] x86_64 boot hang when CONFIG_NUMA=n
On Sun,  6 Jul 2008 13:45:53 +0200 (CEST) Rafael J. Wysocki wrote:

> This message has been generated automatically as a part of a report
> of recent regressions.
>
> The following bug entry is on the current list of known regressions
> from 2.6.25. Please verify if it still should be listed.
>
> Bug-Entry : http://bugzilla.kernel.org/show_bug.cgi?id=10872
> Subject : x86_64 boot hang when CONFIG_NUMA=n
> Submitter : Randy Dunlap <randy.dunlap@oracle.com>
> Date : 2008-06-05 21:50 (32 days old)
> References : http://marc.info/?l=linux-kernel&m=121270308607116&w=4
> http://lkml.org/lkml/2008/6/11/355
> http://lkml.org/lkml/2008/6/15/117
> Handled-By : Yinghai Lu <yhlu.kernel@gmail.com>


This still happens with 2.6.26-rc9. Using CONFIG_NUMA=y boots OK.

The last lines from the (netconsole) log are:

calling early_fill_mp_bus_info+0x0/0x7b2
node 0 link 1: io port [1000, 3fff]
node 1 link 2: io port [4000, ffff]
TOM: 0000000080000000 aka 2048M
node 0 link 1: mmio [e8000000, fddfffff]
node 1 link 2: mmio [fde00000, fdffffff]
node 0 link 1: mmio [80000000, 83ffffff]
node 1 link 2: mmio [84000000, 8fffffff]
node 0 link 1: mmio [a0000, bffff]
TOM2: 0000000280000000 aka 10240M
bus: [00,3f] on node 0 link 1
bus: 00 index 0 io port: [0, 3fff]
bus: 00 index 1 mmio: [90000000, fddfffff]
bus: 00 index 2 mmio: [80000000, 83ffffff]
bus: 00 index 3 mmio: [a0000, bffff]
bus: 00 index 4 mmio: [fe000000, ffffffff]
bus: 00 index 5 mmio: [280000000, fcffffffff]
bus: [40,ff] on node 1 link 2
bus: 40 index 0 io port: [4000, ffff]
bus: 40 index 1 mmio: [fde00000, fdffffff]

---
~Randy
Linux Plumbers Conference, 17-19 September 2008, Portland, Oregon USA
http://linuxplumbersconf.org/

\
 
 \ /
  Last update: 2008-07-06 20:21    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site