lkml.org 
[lkml]   [2008]   [Jul]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [git pull] x86 fixes
Johannes Weiner wrote:
> Hi,
>
> Ingo Molnar <mingo@elte.hu> writes:
>
>
>> Linus,
>>
>> Please pull the latest x86 fixes git tree from:
>>
>> git://git.kernel.org/pub/scm/linux/kernel/git/tip/linux-2.6-tip.git x86-fixes-for-linus
>>
>> Thanks,
>>
>> Ingo
>>
>> ------------------>
>> Jan Kratochvil (1):
>> x86: fix crash due to missing debugctlmsr on AMD K6-3
>>
>> Jeremy Fitzhardinge (2):
>> x86: rename PTE_MASK to PTE_PFN_MASK
>> x86: add PTE_FLAGS_MASK
>>
>
> Are you serious? It goes _this_ fast? The patch came into my mbox at
> 8:00am this morning and you push it to Linus at 4:00pm already?
>
> What about the inconsistency it introduces? When I look at PAGE_MASK
> for example, it masks out the PAGE offset. PTE_MASK masks out PTE
> specifca from a value.
>
> Now, I assume PTE_PFN_MASK masks out the PFN. Oh, wait, it masks the
> protection bits.

PAGE_MASK turns an address into its page address.

PTE_PFN_MASK takes a pte value and returns the pte's pfn portion (which
is shifted so it's actually a page address).

In both cases, the X_MASK terminology means that X is extracted, not
excluded. Which makes sense; if you have a packed bitfield containing
multiple values, you wouldn't expect X to be the list of things *not*
extracted.

(I would be happy to have a PAGE_OFFSET_MASK for all the places where
you want to extract the offset.)

J


\
 
 \ /
  Last update: 2008-07-22 17:11    [W:0.069 / U:0.096 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site