lkml.org 
[lkml]   [2008]   [Jul]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 1/2] x86: rename PTE_MASK to PTE_PFN_MASK
Johannes Weiner wrote:
> PTE_PFN_MASK is not symmetric to PAGE_MASK.

No, it isn't. Is there anything about the name that suggests that it
should be? PTE_PFN_MASK is for operating on pteval_t-typed values
extracted from ptes; PAGE_MASK is for operating on addresses.

> How about PTE_PROT_MASK?
>

That's the opposite sense; the next patch defines it as PTE_FLAGS_MASK.

J


\
 
 \ /
  Last update: 2008-07-22 16:55    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site