lkml.org 
[lkml]   [2008]   [Jul]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH 1/2] x86: rename PTE_MASK to PTE_PFN_MASK
Date
Jeremy Fitzhardinge <jeremy@goop.org> writes:

> Rusty, in his peevish way, complained that macros defining constants
> should have a name which somewhat accurately reflects the actual
> purpose of the constant.
>
> Aside from the fact that PTE_MASK gives no clue as to what's actually
> being masked, and is misleadingly similar to the functionally entirely
> different PMD_MASK, PUD_MASK and PGD_MASK, I don't really see what the
> problem is.

PTE_PFN_MASK is not symmetric to PAGE_MASK. How about PTE_PROT_MASK?

Hannes


\
 
 \ /
  Last update: 2008-07-22 15:07    [W:0.278 / U:0.076 seconds]
©2003-2014 Jasper Spaans. Advertise on this site