lkml.org 
[lkml]   [2008]   [Jul]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: [PATCH] x86: add apic probe for genapic 64bit v2

    * Ingo Molnar <mingo@elte.hu> wrote:

    > > v2: fix compiling when CONFIG_ACPI is not set
    >
    > applied to tip/x86/x2apic - thanks Yinghai.
    >
    > > +static struct genapic *apic_probe[] __initdata = {
    > > + &apic_x2apic_uv_x,
    > > + &apic_x2apic_phys,
    > > + &apic_x2apic_cluster,
    > > + &apic_physflat,
    > > + NULL,
    > > +};
    >
    > very nice generalization!

    btw.:

    apic_probe[i]->acpi_madt_oem_check

    should probably be renamed to something more neutral like "->probe" -
    there's nothing ACPI about it and some weird boxes could use PCI or
    other probing mechanisms to discover the type of APIC they want to use.

    plus i guess genapic_32.h and genapic_64.h should be unified and struct
    apic_ops should be put into struct genapic?

    Ingo


    \
     
     \ /
      Last update: 2008-07-22 09:15    [W:0.050 / U:1.280 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site