lkml.org 
[lkml]   [2008]   [Jul]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: Problem: Load average of 6, no I/O, 25% idle time. Why?
    On Fri, Jul 18, 2008 at 9:28 AM, Peter Zijlstra <peterz@infradead.org> wrote:
    > On Fri, 2008-07-18 at 08:49 -0400, Timothy Normand Miller wrote:
    >> I have a four processor box, running three compute loads. The kernel
    >> I'm running is 2.6.25-gentoo-r5.
    >>
    >> One process has four threads, and it's niced to 19.
    >> Another process has one thread and is niced to -10
    >> The last process has one thread and is niced to 0
    >>
    >> One processor is always idle.
    >>
    >> If I change either the 0 to a -10 or the -10 to a zero, then all four
    >> cores are properly utilized.

    Interesting corollary: If the only thing running is the one nice=19,
    four-thread process, then there's about 4% idle time. I have to raise
    the priority to get the idle time to go away. Since when do active
    processes yield to idle time?

    Two of my three loads are finished, so when this last one is done,
    I'll try 2.6.26. Was something like this actively discussed and fixed
    between 2.6.25 and 2.6.26?

    Thanks.


    --
    Timothy Normand Miller
    http://www.cse.ohio-state.edu/~millerti
    Open Graphics Project


    \
     
     \ /
      Last update: 2008-07-19 00:19    [W:0.021 / U:29.788 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site