[lkml]   [2008]   [Jul]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: [GIT *] Allow request_firmware() to be satisfied from in-kernel, use it in more drivers.
    On Tue, 2008-07-15 at 17:14 -0400, Jeff Garzik wrote:
    > Linus Torvalds wrote:
    > >
    > > On Tue, 15 Jul 2008, Jeff Garzik wrote:
    > >> Already started, in fact, since Linus said he would not reject it out of
    > >> hands.
    > >
    > > Btw, I need to see it actually solve a real problem. As it is, I really
    > > think you've just painted yourself into a corner where you can't just
    > > admit that we can just load the firmware directly.
    > Kernel 2.6.26. Older userland w/ initrd requirement, plus module w/
    > compiled-in firmware.
    > Simply dropping 2.6.27 into that situation will produce an unbootable
    > system, since the firmware would not get copied into the initrd.

    Kernel 2.6.15 with ancient userland. You update to 2.6.16, which
    includes commit 5433383e ('convert qla2xxx to request_firmware()').

    Same problem? Only three years ago. And not really a problem back then
    either, because _even_ then you had to have a fairly ancient userland
    for it not to work.

    You're far too late to start whining about it now, Jeff. We're just
    cleaning up the last drivers now. The rest have been where we want them
    to be for _years_.


     \ /
      Last update: 2008-07-15 23:27    [W:0.039 / U:13.440 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site