lkml.org 
[lkml]   [2008]   [Jun]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    From
    SubjectRe: fb layer & ioremap_wc
    Date
    On Monday 05 May 2008, Jesse Barnes wrote:
    > On Monday, May 05, 2008 11:59 am Frans Pop wrote:
    > > On Monday 05 May 2008, you wrote:
    > > > On Monday, May 05, 2008 10:32 am Frans Pop wrote:
    > > > > I suspect it could be vesafb/fbcon related instead. Normally I
    > > > > boot my system with 'quiet vga=791', i.e. with vesafb. I then see
    > > > > the artifacts.
    > > > >
    > > > > When I boot with 'video=vfb:off', I do _not_ get the artifacts
    > > > > when X exits.
    > > >
    > > > Ahhh, I missed that part of your config. That could definitely
    > > > have an effect on things... You'll probably want something like
    > > > the attached
    > >
    > > Not sure what to make of this.
    > > With your patch I still get the artifacts, but they are displayed a
    > > lot shorter. I get only a flash instead of a-2 seconds.
    >
    > Hm, so I guess some other user is still using UC on the region. [Note
    > to fb list: the patch just made vesafb use ioremap_wc instead of
    > ioremap).

    AFAIK there has been no progress on this issue, which is now listed on the
    regression list for .26 [1]. As there has been no response from any fb
    devs, is someone else maybe willing to have a closer look at this?

    I'm still seeing the artifacts with -rc6 and the severity seems to depend
    on what was last displayed: sometimes the whole display is covered with
    colored nonsense, artistic maybe but not desired...

    Cheers,
    FJP

    [1] http://bugzilla.kernel.org/show_bug.cgi?id=10843


    \
     
     \ /
      Last update: 2008-06-13 18:45    [W:0.021 / U:0.108 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site