lkml.org 
[lkml]   [2008]   [May]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: 2.6.25.3: su gets stuck for root
    On Tue, May 13, 2008 at 7:43 PM, Harald Dunkel
    <harald.dunkel@t-online.de> wrote:
    > Vegard Nossum wrote:
    >
    > > Can you try to run "strace su someuser" instead?
    >
    > I tried, but its a Heisenbug: If I run it with strace (with or without
    > -f), then it doesn't get stuck.

    Ah, tough luck. What if you attach an strace to the already stuck
    process? Like strace -p pid. It's a long shot, but worth a try, I
    suppose.

    You could also try to use sysrq to output some useful information
    about the stuck process. See Documentation/sysrq.txt for more
    information. Gotta run, good luck!

    Vegard

    --
    "The animistic metaphor of the bug that maliciously sneaked in while
    the programmer was not looking is intellectually dishonest as it
    disguises that the error is the programmer's own creation."
    -- E. W. Dijkstra, EWD1036


    \
     
     \ /
      Last update: 2008-05-14 09:37    [W:0.021 / U:118.088 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site