lkml.org 
[lkml]   [2008]   [Mar]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [2.6 patch] SCSI_AIC94XX must depend on SCSI
On Thu, Mar 06, 2008 at 02:31:07PM -0600, James Bottomley wrote:
> On Thu, 2008-03-06 at 22:22 +0200, Adrian Bunk wrote:
> > This patch fixes the following build error reported by Toralf Förster:
> >
> > <-- snip -->
> >
> > ...
> > MODPOST 243 modules
> > ERROR: "sas_bios_param" [drivers/scsi/mvsas.ko] undefined!
> > ERROR: "sas_change_queue_type" [drivers/scsi/mvsas.ko] undefined!
> > ERROR: "sas_change_queue_depth" [drivers/scsi/mvsas.ko] undefined!
> > ERROR: "sas_target_destroy" [drivers/scsi/mvsas.ko] undefined!
> > ERROR: "sas_target_alloc" [drivers/scsi/mvsas.ko] undefined!
> > ERROR: "sas_slave_destroy" [drivers/scsi/mvsas.ko] undefined!
> > ERROR: "sas_slave_configure" [drivers/scsi/mvsas.ko] undefined!
> > ERROR: "sas_eh_bus_reset_handler" [drivers/scsi/mvsas.ko] undefined!
> > ERROR: "sas_eh_device_reset_handler" [drivers/scsi/mvsas.ko] undefined!
> > ERROR: "sas_queuecommand" [drivers/scsi/mvsas.ko] undefined!
> > ERROR: "sas_ioctl" [drivers/scsi/mvsas.ko] undefined!
> > ERROR: "sas_register_ha" [drivers/scsi/mvsas.ko] undefined!
> > ERROR: "sas_domain_attach_transport" [drivers/scsi/mvsas.ko] undefined!
> > ERROR: "sas_ssp_task_response" [drivers/scsi/mvsas.ko] undefined!
> > ERROR: "sas_slave_alloc" [drivers/scsi/mvsas.ko] undefined!
> > ERROR: "sas_unregister_ha" [drivers/scsi/mvsas.ko] undefined!
> > make[1]: *** [__modpost] Error 1
> >
> > <-- snip -->
> >
> > Signed-off-by: Adrian Bunk <bunk@kernel.org>
> >
> > ---
> > --- a/drivers/scsi/aic94xx/Kconfig
> > +++ b/drivers/scsi/aic94xx/Kconfig
> > @@ -26,7 +26,7 @@
> >
> > config SCSI_AIC94XX
> > tristate "Adaptec AIC94xx SAS/SATA support"
> > - depends on PCI
> > + depends on SCSI && PCI
> > select SCSI_SAS_LIBSAS
> > select FW_LOADER
>
> This doesn't look to be a fix for your error: the symbols you've listed
> as missing are all libsas ones, not core SCSI ones. Also they're all
> claiming to be missing from mvsas, not aic94xx. There's something else
> about the configuration that produced this error.

This is the right fix for this bug.

We have:
- SCSI=m
- SCSI_AIC94XX=y
- SCSI_MVSAS=m
- SCSI_SAS_LIBSAS=y

The problem is:
- SCSI_AIC94XX selects (and requires) SCSI_SAS_LIBSAS
- SCSI_MVSAS selects (and requires) SCSI_SAS_LIBSAS
- with SCSI=m a SCSI_SAS_LIBSAS=y is not linked into the kernel

SCSI_AIC94XX=y also results in the AIC94xx driver not being linked into
the kernel here (and that's also fixed by this patch), but this alone
wouldn't result in a build bug...

> James

cu
Adrian

--

"Is there not promise of rain?" Ling Tan asked suddenly out
of the darkness. There had been need of rain for many days.
"Only a promise," Lao Er said.
Pearl S. Buck - Dragon Seed

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2008-03-06 22:43    [W:0.037 / U:0.616 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site