lkml.org 
[lkml]   [2008]   [Mar]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: processor flags
Cyrill Gorcunov wrote:
>
> And now I'm in confusion - the way of changing this code I see is the
> following:
>
> - or use additional #ifdef CONFIG_VM86 in code where VM_MASK is used
> (that would be ugly IMHO)
> - rename VM_MASK to say X86_EFLAGS_VM86 with that #ifdef remained
> - rest VM_MASK as it is
>
> How do you think?
>

I think what we should do is:

- Rename VM_MASK to X86_VM_MASK (it's x86-specific after all)
- Have:

#if CONFIG_VM86
# define X86_VM_MASK X86_EFLAGS_VM
#else
# define X86_VM_MASK 0 /* No V86 support */
#endif

-hpa


\
 
 \ /
  Last update: 2008-03-27 20:59    [W:1.066 / U:0.008 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site