[lkml]   [2008]   [Mar]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH] Corrections to Documentation/rbtree.txt
On 20/03/08 18:39, Rob Landley wrote:
> On Thursday 20 March 2008 10:29:57 Ian Abbott wrote:
>> From: Ian Abbott <>
>> The description of the rb_entry() macro in Documentation/rbtree.txt seems
>> incorrect. This patch improves it (hopefully). Also I changed the example
>> code to call the previous 'my_search()' example instead of an undefined
>> 'mysearch()'.
> I have no objection to the patch (and the my_search thing seems like an
> obvious typo), but is there a reason to prefer rb_entry() rather than
> container_of()? If so, the rationale might be a good thing to add to the
> documentation...

I forgot to mention this in my earlier post, but while we're on the
subject, it might be worth renaming the 'node' variable in the
'my_search()' and iteration examples to avoid confusion in the use of
the rb_entry() (or container_of() macro), for example in 'my_search()',
instead of:

struct rb_node *node = root->rb_node;

while (node) {
struct mytype *data = rb_entry(node, struct mytype, node);

I think this is clearer:

struct rb_node *pn = root->rb_node;

while (pn) {
struct mytype *data = rb_entry(pn, struct mytype, node);

(I used rb_entry instead of container_of in the above. Also, there are
probably better, longer variable names than 'pn', e.g. 'rbn' or 'rbnode'
or 'pnode'.)

-=( Ian Abbott @ MEV Ltd. E-mail: <> )=-
-=( Tel: +44 (0)161 477 1898 FAX: +44 (0)161 718 3587 )=-

 \ /
  Last update: 2008-03-25 12:33    [W:0.062 / U:3.596 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site