lkml.org 
[lkml]   [2008]   [Mar]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 0/3, v10] PCI, ACPI: Physical PCI slot objects
Matthew Wilcox wrote:
> On Tue, Mar 18, 2008 at 03:05:39PM -0600, Alex Chiang wrote:
>> Also, v10 should fix the "pci_slot module changes the sysfs name"
>> issue that Kenji-san was seeing.
>
> I thought we agreed that the current names are wrong, and we shouldn't
> consider this 'different name' an issue.
>

I also think that the current names are wrong. But even if we fix the
slot name of shpchp/pciehp, it doesn't ensure that slot names are same
among pci_slot.ko and the other hotplug dirvers.

BTW, I'm planning to suggest the patch for shpchp/pciehp to use slot
number as a slot name (as they used to do), and add a module option
to use the combination of bus number and slot number as a slot name
as a workaround for problematic platforms.

Thanks,
Kenji Kaneshige



\
 
 \ /
  Last update: 2008-03-20 05:01    [from the cache]
©2003-2011 Jasper Spaans