lkml.org 
[lkml]   [2008]   [Mar]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    Subject[Regression: 2.6.25-rc5: Blank Screen: Intel 945]
    Hi,

    I'm not sure, but I think I've found a regression in the latest development kernel (2.6.25-rc5).
    The problems don't happen when using the distro's 2.6.22 kernel (ubuntu 7.10), or when I was testing 2.6.23 and 2.6.24.

    These are the problems I've been having:

    1) Blank screen: Upon entering graphical mode the screen goes blank (black). It seems to happen when X is probing for the video modes.
    Pressing ctrl+alt+f1 doesn't do anything, except "refresh" a black screen. The computer still works, and I can log in from GDM,
    but I just can't see anything on the screen; I have to reboot.
    The work around is that when the boot splash screen (usplash) is about halfway loaded I switch to the first terminal,
    and everything is fine (or maybe that's just a coincidence).

    2) Wireless errors: Upon connecting to a wireless router I get a flood of kernel messages that don't stop:
    "kernel: wlan0_rename: RX too short data frame payload".
    I do successfully connect. No workaround to stop the messages (while still having connection).

    3) Flashing Red: When I shutdown, the screen flashes red several times before the shutdown splash screen shows up.

    #1 and #3 happen at random. Although, It seems to happen more on the first boot up.
    #2 consistently happens when connecting to my University's wireless; rarely (if ever) on my home router.

    Relevant sysinfo (Dell Inspiron E1505; Intel T2080 @ 1.73GHz):
    0b:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
    00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
    00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)

    Could this be a regression? What can I do to help identify the problem?
    I've tried to start analyzing the blank screen problem, so let's start there because I've already created a diff log report.

    For a diff of my system logs for the blank screen problem see (104.61 KB):
    http://jdserver.homelinux.org/linux/blank_screen_log_diff.txt

    For full details about my system see (23.14 KB):
    http://jdserver.homelinux.org/linux/sysinfo-2.6.25-rc5.txt

    For my config file that I used see (40.84 KB):
    http://jdserver.homelinux.org/linux/config-2.6.25-rc5

    Hopefully this helps and I can get my problems solved.

    Thanks



    \
     
     \ /
      Last update: 2008-03-12 20:11    [W:0.024 / U:89.648 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site