lkml.org 
[lkml]   [2008]   [Mar]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH] [6/13] Core maskable allocator
From
Date
Hi, Andi,

As I dig through this patch, I find it mostly makes sense; seems like it
could be a good idea. I did have one little API question...

> +struct page *
> +alloc_pages_mask(gfp_t gfp, unsigned size, u64 mask)
> +{
> + unsigned long max_pfn = mask >> PAGE_SHIFT;

The "mask" parameter isn't really a mask - it's an upper bound on the
address of the allocated memory. Might it be better to call it
"max_addr" or "limit" or "ceiling" or some such so callers understand
for sure how it's interpreted? The use of the term "mask" throughout
the interface could maybe create a certain amount of confusion.

Thanks,

jon


\
 
 \ /
  Last update: 2008-03-11 16:37    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site