[lkml]   [2008]   [Feb]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectInteractivity issue in 2.6.25-rc3
    I want to report a bad interactivity which happened in my 
    desktop running the latest kernel (2.6.25-rc3-00081-g7704a8b).

    I tried to play 'flightgear' and the desktop became _very_
    slow while flightgear was "loading scenery objects" (a task
    which never finished and I could not play it).

    The desktop is a P4 @ 3.0 GHz, 512MB, with the nv graphics

    I ran 'fgfs' firstly as a regular user (mafra) and tried to execute
    Ingo's cfs-debug script as root in a terminal (mrxvt) which had 3 open
    tabs. It took minutes to switch tabs and run, which
    completed its job only after I managed to kill flightgear (after more
    than a couple minutes). The result is here:

    [ I want to emphasize that I started the script while the system
    was slow, waited a few minutes, killed flightgear, and then
    the script finished its job. ]

    As I have the group scheduler enabled, I tried to run flightgear as
    root to see what happens. I could not even start to run the debug
    script, because each letter I typed took many seconds to appear.

    The mouse pointer however was responsive, but Window Maker wasn't.
    I tried to switch desktops, and after a few minutes the pressing
    of "Alt+5" took effect and the desktop 5 appeared ok in the screen.

    Then I tried to go back to desktop 1 with "Alt+1" and after exactly
    12 minutes I gave up and hit "Ctrl-Alt-Backspace". After 5 or
    10 seconds X was killed and everything was normal
    again (no need to reboot).

    Is this experience normal? I know that trying to play a game without
    3D is a crazy thing, but it didn't feel _fair_ to wait minutes to
    see the result of a key press.

     \ /
      Last update: 2008-02-28 19:45    [W:0.027 / U:61.256 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site