[lkml]   [2008]   [Feb]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: [Xen-devel] [PATCH] let XEN depend on PAE
    Arnd Hannemann wrote:
    > Jeremy Fitzhardinge wrote:
    >> Arnd Hannemann wrote:
    >>> This is with, but latest-git looks the same:
    >>> I also tried with 2.6.23 which crashes instantly, without any output
    >>> of the guest.
    >> I'm not too surprised. Non-PAE Xen is a bit of a rarity, and it only
    >> gets tested rarely. Chris Wright did spend some time on it a while ago,
    >> but I don't know that its had any real attention since. I've been
    >> making sure non-PAE compiles, but I've been lax about testing it.
    >> This is the first usermode exec, I guess? The backtrace is a bit odd;
    >> I've never seen a problem in move_page_tables before.
    > Yes its trying to execute the first script in initramfs, I also tried with initramdisk
    > and got a similar error. (move_page_tables also involved)
    >> Does "xm dmesg" tell you what Xen is complaining about? You may need to
    >> compile with debug=y in
    > (XEN) mm.c:645:d44 Non-privileged (44) attempt to map I/O space 00000000
    > I will recompile with debug=y and post the output.
    > If I reduce the dom0 memory with dom0_mem=200000 I see something like
    > 00000080 with dom0_mem=800000 I always see 00000000.

    That's helpful. Looks like the mfn is getting mushed to 0.


     \ /
      Last update: 2008-02-22 22:19    [W:0.021 / U:35.580 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site