lkml.org 
[lkml]   [2008]   [Feb]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    Patch in this message
    /
    Date
    From
    SubjectKVM is not seen under X86 config with latest git (32 bit compile)

    The KVM configuration is no longer visible in the latest git tree. It looks
    like it is selected by HAVE_SETUP_PER_CPU_AREA. I've moved HAVE_KVM to
    under CONFIG_X86. Hopefully, this is the right fix.

    Comments?

    Signed-off-by: Balbir Singh <balbir@linux.vnet.ibm.com>
    ---

    arch/x86/Kconfig | 4 ++--
    1 file changed, 2 insertions(+), 2 deletions(-)

    diff -puN arch/x86/Kconfig~fix-kvm-build arch/x86/Kconfig
    --- linux-2.6-git/arch/x86/Kconfig~fix-kvm-build 2008-02-10 12:41:18.000000000 +0530
    +++ linux-2.6-git-balbir/arch/x86/Kconfig 2008-02-10 12:41:37.000000000 +0530
    @@ -20,6 +20,8 @@ config X86
    def_bool y
    select HAVE_OPROFILE
    select HAVE_KPROBES
    + select HAVE_KVM
    +

    config GENERIC_LOCKBREAK
    def_bool n
    @@ -108,8 +110,6 @@ config GENERIC_TIME_VSYSCALL
    config HAVE_SETUP_PER_CPU_AREA
    def_bool X86_64

    -select HAVE_KVM
    -
    config ARCH_HIBERNATION_POSSIBLE
    def_bool y
    depends on !SMP || !X86_VOYAGER
    _
    --
    Warm Regards,
    Balbir Singh
    Linux Technology Center
    IBM, ISTL

    \
     
     \ /
      Last update: 2008-02-10 08:21    [W:0.048 / U:30.616 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site