[lkml]   [2008]   [Dec]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH] ring_bufer: fix BUF_PAGE_SIZE

On Sun, 21 Dec 2008, Ingo Molnar wrote:
> * Lai Jiangshan <> wrote:

> > In the old codes, these lines confuse me:
> > return (addr & ~PAGE_MASK) - (PAGE_SIZE - BUF_PAGE_SIZE);
> > addr &= PAGE_MASK;
> > This patch mostly make the codes concordant.
> ah, okay. Steve, any strong feelings against the patch? And we might just
> go for removing BUF_PAGE_SIZE itself instead.

I'll need to rename BUF_PAGE_SIZE to BUF_SIZE since it is really the size
of a buffer per page. The pages will now have some header information on
it to let things like splice take the page away and still be able to
translate what is on the page.

-- Steve

 \ /
  Last update: 2008-12-22 19:39    [W:0.067 / U:2.956 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site