lkml.org 
[lkml]   [2008]   [Dec]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: BUG - HDA Intel very low audio with breaking voice in 2.6.28-rc8
At Sun, 14 Dec 2008 13:28:56 +0530,
Jaswinder Singh wrote:
>
> Hello all,
>
> I am facing problem in 2.6.28-rc8, HDA Intel audio is very low and
> with breaking voice, may be it seems like HD effect ;)

What do you mean "breaking voice"? Please be more specific.

Run alsa-info.sh with --no-upload option, and attach the generated
file. This will contain the detailed hardware information. The
script is found at
http://www.alsa-project.org/alsa-info.sh

Is this a regression from the older kernel? If yes, please run
alsa-info on both working and non-working kernels and attach the both
outputs.
git://git.kernel.org/pub/scm/linux/kernel/git/tiwai/sound-2.6.git

Also, try the latest sound git tree whether the problem persists on
the latest version.

You can find some other information on
ftp://ftp.kernel.org/pub/linux/kernel/people/tiwai/docs/HD-Audio.pdf


Takashi


>
> dmesg :
>
> HDA Intel 0000:00:14.2: PCI INT A -> GSI 16 (level, low) -> IRQ 16
> HDA Intel 0000:00:14.2: setting latency timer to 64
> ALSA sound/pci/hda/hda_codec.c:3055: autoconfig: line_outs=1
> (0xd/0x0/0x0/0x0/0x0)
> ALSA sound/pci/hda/hda_codec.c:3059: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
> ALSA sound/pci/hda/hda_codec.c:3063: hp_outs=1 (0xa/0x0/0x0/0x0/0x0)
> ALSA sound/pci/hda/hda_codec.c:3064: mono: mono_out=0x0
> ALSA sound/pci/hda/hda_codec.c:3072: inputs: mic=0xb, fmic=0x0,
> line=0xe, fline=0x0, cd=0x0, aux=0x0
> HDA Intel 0000:01:05.1: PCI INT B -> GSI 19 (level, low) -> IRQ 19
> HDA Intel 0000:01:05.1: setting latency timer to 64
>
> /sbin/lspci -vv :
> 00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia
> Subsystem: Hewlett-Packard Company Device 30f2
> Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
> Stepping- SERR- FastB2B- DisINTx-
> Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=slow >TAbort-
> <TAbort- <MAbort- >SERR- <PERR- INTx-
> Latency: 64
> Interrupt: pin ? routed to IRQ 16
> Region 0: Memory at d2400000 (64-bit, non-prefetchable) [size=16K]
> Capabilities: [50] Power Management version 2
> Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
> Status: D0 PME-Enable- DSel=0 DScale=0 PME-
> Kernel driver in use: HDA Intel
> Kernel modules: snd-hda-intel
>
>
> 01:05.1 Audio device: ATI Technologies Inc RS780 Azalia controller
> Subsystem: Hewlett-Packard Company Device 30f2
> Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
> Stepping- SERR- FastB2B- DisINTx-
> Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort-
> <TAbort- <MAbort- >SERR- <PERR- INTx-
> Latency: 0
> Interrupt: pin B routed to IRQ 19
> Region 0: Memory at d2310000 (32-bit, non-prefetchable) [size=16K]
> Capabilities: [50] Power Management version 3
> Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
> Status: D0 PME-Enable- DSel=0 DScale=0 PME-
> Capabilities: [a0] Message Signalled Interrupts: Mask- 64bit+ Count=1/1 Enable-
> Address: 0000000000000000 Data: 0000
> Kernel driver in use: HDA Intel
> Kernel modules: snd-hda-intel
>
> If you need more information, please let me know.
>
> I am also curious why it is showing 2 audio devices with lspci. I am
> using HP dv5-1002us laptop.
>
> Thank you,
>
> Jaswinder Singh.
>


\
 
 \ /
  Last update: 2008-12-14 10:29    [from the cache]
©2003-2011 Jasper Spaans