lkml.org 
[lkml]   [2008]   [Nov]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectWARNING: at drivers/ata/libata-eh.c:3247 ata_eh_finish+0x7c/0x8b()
Hi all,

Just hotplugged a suspect SATA hard drive into my system. I guess it is
suspect as there were media errors being logged, but I'm guessing this isn't
supposed to happen:

------------[ cut here ]------------
WARNING: at drivers/ata/libata-eh.c:3247 ata_eh_finish+0x7c/0x8b()
Modules linked in: isofs zlib_inflate ntfs vfat fat xt_tcpudp gbt_odin
iptable_filter ip_tables x_tables nfs nfsd lockd nfs_acl sunrpc exportfs
uinput snd_pcm_oss snd_mixer_oss snd_seq_dummy snd_seq_oss snd_seq_midi_event
snd_seq snd_seq_device coretemp it87 hwmon_vid vboxdrv nvidiafb fb fb_ddc
i2c_algo_bit cfbcopyarea vgastate cfbimgblt cfbfillrect r8169 i2c_i801
snd_hda_intel nvidia(P) snd_pcm snd_timer snd_page_alloc snd_hwdep iTCO_wdt
psmouse snd serio_raw joydev usbhid hid [last unloaded: xt_LED]
Pid: 1001, comm: scsi_eh_3 Tainted: P 2.6.28-rc2 #4
Call Trace:
[<ffffffff802327db>] warn_on_slowpath+0x51/0x6d
[<ffffffff803eef7e>] ahci_postreset+0x0/0x66
[<ffffffff803ef0b6>] ahci_hardreset+0x0/0xe6
[<ffffffff803eed39>] ahci_softreset+0x0/0x37
[<ffffffff803df29f>] ata_std_prereset+0x0/0xb7
[<ffffffff803e6e12>] ata_eh_finish+0x7c/0x8b
[<ffffffff803eb3b3>] sata_pmp_error_handler+0x9f8/0xa92
[<ffffffff80241674>] __cancel_work_timer+0x2f/0x158
[<ffffffff80500e0d>] _spin_lock_irqsave+0x18/0x34
[<ffffffff8023b12d>] lock_timer_base+0x26/0x4b
[<ffffffff803da2c5>] ata_wait_register+0x34/0x70
[<ffffffff803e7960>] ata_scsi_error+0x2d7/0x57f
[<ffffffff803c443f>] scsi_error_handler+0x5d/0x2b1
[<ffffffff803c43e2>] scsi_error_handler+0x0/0x2b1
[<ffffffff80244380>] kthread+0x47/0x73
[<ffffffff8020c189>] child_rip+0xa/0x11
[<ffffffff80244339>] kthread+0x0/0x73
[<ffffffff8020c17f>] child_rip+0x0/0x11
---[ end trace 066d358fba7ac325 ]---
I doubt the nvidia module has anything to do with this, but if you want me to
reproduce this on a clean kernel let me know. I can't reproduce it now as
that SATA port appears to be dead...

Please let me know if you need any further info.

Cheers,
Adam.


\
 
 \ /
  Last update: 2008-11-22 13:31    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site