lkml.org 
[lkml]   [2008]   [Nov]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] x86: fix wakeup_cpu with numaq/es7000 v2

* Cyrill Gorcunov <gorcunov@gmail.com> wrote:

> [Ingo Molnar - Mon, Nov 17, 2008 at 05:52:24PM +0100]
> |
> | * Yinghai Lu <yinghai@kernel.org> wrote:
> |
> | > Impact: fix wakeup path with numaq and es7000
> |
> | applied to tip/x86/quirks, thanks Yinghai!
> |
> | A couple of comments:
> |
> | > +static inline void inquire_remote_apic(int apicid)
> | > +{
> | > + if (apic_verbosity >= APIC_DEBUG)
> | > + __inquire_remote_apic(apicid);
> | > +}
> |
>
> Btw, Ingo, Yinghai,
>
> it's a bit weird but I found that we use apic_verbosity
> here to _do_ something (ie touching circuit) but on any
> other cases apic_verbosity is just a additional logging
> filter so -- what the initial apic_verbosity purpose was?
> If it's just a logging filter (to which I'm more biased)
> this case is plain wrong. But if apic_verbosity is not
> like this -- then it's fine. Since I was not initial author
> of the code -- I'm asking you :)

the reason why it's dependent on apic_verbosity is that the
inquire_remote_apic() function is a debug function which we only call
if we fail to start up a secondary CPU.

Perhaps renaming it to debug_print_remote_apic() would have made that
more obvious.

Ingo


\
 
 \ /
  Last update: 2008-11-17 18:39    [W:1.773 / U:0.016 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site