[lkml]   [2008]   [Nov]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 2/2] tracing/function-return-tracer: Call prepare_ftrace_return by registers

> Hmm... The whole thing is splitted in two levels: the infrastructure
> to trace on call and return (and call
> a return handler) and the higher level tracer.
> The first could be called ftrace_exit because it is waht it does.
> And the second is much more about cost evaluation of functions and so
> could be named function_cost. Its
> functions and structures could have this in their name whereas the low
> level things could have ftrace_exit in
> their name.
> What do you think?

Yeah, I like that.

Ingo, what's your thought on that?

-- Steve

 \ /
  Last update: 2008-11-13 01:15    [from the cache]
©2003-2011 Jasper Spaans