lkml.org 
[lkml]   [2008]   [Nov]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    SubjectRe: ACPI crash on lid close - SMP race?
    From
    Date
    well, there is a bug report for this problem:
    http://bugzilla.kernel.org/show_bug.cgi?id=11259

    and there are some bug reports for a similar problem (system crashes on
    lid close if _DOS=1, but on a UP platform).
    http://bugzilla.kernel.org/show_bug.cgi?id=6001#c49

    but unfortunately we haven't made any progress in this issue. :(

    thanks,
    rui

    On Tue, 2008-11-11 at 00:11 +0800, Matthew Garrett wrote:
    > If the _DOS flag on my HP 2510p is set to 0 (ie, signal OS when screen
    > notification is requested, don't change automatically) then it'll crash
    > on random lid open/closes. The trace generally makes little sense and
    > depends on the kernel version and phase of the moon. I'd ignored this as
    > firmware brokenness up until lately, but since having _DOS set to 0 is
    > the only way to get a notification when the display switch key is
    > pressed on this machine I'd be interested in fixing it properly.
    >
    > Unfortunately, I've got no real idea what on earth is going on. The only
    > clue I've found so far is that booting with maxcpus=1 leaves it working
    > perfectly. What parts of the ACPI stack could be triggering this?
    >



    \
     
     \ /
      Last update: 2008-11-11 02:33    [W:0.023 / U:30.252 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site