lkml.org 
[lkml]   [2008]   [Oct]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: pm_op(): pci_pm_restore+0x0/0x70 returns -16
Date
On Wednesday, 29 of October 2008, Pascal Terjan wrote:
> On Wed, Oct 29, 2008 at 12:18 AM, Rafael J. Wysocki <rjw@sisk.pl> wrote:
> > On Tuesday, 28 of October 2008, Pascal Terjan wrote:
> >> Since I updated my laptop (Thikpad T40) to 2.6.27-rc5 and all new
> >> kernels until 2.6.27.3 (was using 2.6.25 before), I get this at resume
> >> time after hibernation :
> >>
> >> Oct 28 10:39:18 plop kernel: pm_op(): pci_pm_restore+0x0/0x70 returns
> >> -16
> >> Oct 28 10:39:19 plop kernel: PM: Device 0000:00:00.0 failed to restore:
> >> error -16
> >>
> >> This may or may not be related to resume issues I often get.
> >>
> >> Sometimes it still work fine, sometimes it panics but I can't get any
> >> log, sometimes I get back to X but without USB mouse, without keyboard
> >> and ssh not responding (sysrq still work).
> >
> > It looks like the ->restore() callback fails for your hostbridge. It might
> > have done that before, but we've only been reporting such failures since the
> > 2.6.27 development cycle.
> >
> > Did hibernation work correctly with 2.6.25?
>
> Yes it worked fine
> I hibernate twice a day and never got failures with old kernels while
> it now fails to resume most of the time, but other things have changed
> and I did not do any investigation (for example I switched to libata
> while switching to 2.6.27-rc).
> If this message is only additional reporting, i will try to do some more testing

Yes, this printk() got introduced in 2.6.27.

Thanks,
Rafael


\
 
 \ /
  Last update: 2008-10-29 22:27    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site