lkml.org 
[lkml]   [2008]   [Oct]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v6-resend 00/17] PCI: let the core manage slot names
I tested the set of patches using pci_slot, pciehp and shpchp
driver. Looks good.

Acked-by: Kenji Kaneshige <kaneshige.kenji@jp.fujitsu.com>


Alex Chiang wrote:
> Sorry, I had a botchup with stgit (not sure why it did not send out
> all the patches in my series).
>
> This thread should contain all 17 patches in the series.
>
> Thanks.
>
> /ac
>
> ---
>
> Alex Chiang (16):
> PCI Hotplug: fakephp: add duplicate slot name debugging
> PCI: Hotplug core: remove 'name'
> PCI: shcphp: remove 'name' parameter
> PCI: SGI Hotplug: stop managing bss_hotplug_slot->name
> PCI: rpaphp: kmalloc/kfree slot->name directly
> PCI: pciehp: remove 'name' parameter
> PCI: ibmphp: stop managing hotplug_slot->name
> PCI: fakephp: remove 'name' parameter
> PCI: cpqphp: stop managing hotplug_slot->name
> PCI: cpci_hotplug: stop managing hotplug_slot->name
> PCI: acpiphp: remove 'name' parameter
> PCI, PCI Hotplug: introduce slot_name helpers
> PCI: prevent duplicate slot names
> PCI: update pci_create_slot() to take a 'hotplug' param
> PCI: rename pci_update_slot_number to pci_renumber_slot
> PCI Hotplug core: add 'name' param pci_hp_register interface
>
> Kenji Kaneshige (1):
> PCI Hotplug: serialize pci_hp_register and pci_hp_deregister
>
>
> drivers/acpi/pci_slot.c | 2
> drivers/pci/hotplug/acpiphp.h | 9 +-
> drivers/pci/hotplug/acpiphp_core.c | 32 +++---
> drivers/pci/hotplug/cpci_hotplug.h | 6 +
> drivers/pci/hotplug/cpci_hotplug_core.c | 75 ++++++---------
> drivers/pci/hotplug/cpci_hotplug_pci.c | 4 -
> drivers/pci/hotplug/cpqphp.h | 13 +--
> drivers/pci/hotplug/cpqphp_core.c | 43 ++++----
> drivers/pci/hotplug/fakephp.c | 26 +++--
> drivers/pci/hotplug/ibmphp.h | 5 -
> drivers/pci/hotplug/ibmphp_ebda.c | 19 +---
> drivers/pci/hotplug/pci_hotplug_core.c | 64 ++++--------
> drivers/pci/hotplug/pciehp.h | 9 +-
> drivers/pci/hotplug/pciehp_core.c | 49 +++------
> drivers/pci/hotplug/pciehp_ctrl.c | 53 ++++++----
> drivers/pci/hotplug/pciehp_hpc.c | 1
> drivers/pci/hotplug/rpaphp_slot.c | 10 +-
> drivers/pci/hotplug/sgi_hotplug.c | 18 +--
> drivers/pci/hotplug/shpchp.h | 9 +-
> drivers/pci/hotplug/shpchp_core.c | 52 ++++------
> drivers/pci/hotplug/shpchp_ctrl.c | 48 +++++----
> drivers/pci/slot.c | 160 +++++++++++++++++++++++--------
> include/linux/pci.h | 10 ++
> include/linux/pci_hotplug.h | 11 +-
> 24 files changed, 382 insertions(+), 346 deletions(-)
>
> --
> To unsubscribe from this list: send the line "unsubscribe linux-pci" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at http://vger.kernel.org/majordomo-info.html
>
>




\
 
 \ /
  Last update: 2008-10-15 18:55    [W:0.056 / U:0.052 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site