lkml.org 
[lkml]   [2008]   [Jan]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [BUILD FAILURE]2.6.24-git6 build failure on sis190 ethernet driver
Gabriel C wrote:
> Kamalesh Babulal wrote:
>> Hi,
>>
>> The 2.6.24-git6 kernel build fails on various x86_64 machines with the build failure
>>
>> drivers/net/sis190.c:329: error: sis190_pci_tbl causes a section type conflict
>> make[2]: *** [drivers/net/sis190.o] Error 1
>>
>> # gcc --version (machine1)
>> gcc (GCC) 4.1.1 20070105 (Red Hat 4.1.1-52)
>>
>> # gcc --version (machine2)
>> gcc (GCC) 4.1.1 20060525 (Red Hat 4.1.1-1)
>>
>
> Heh :) vger.kernel.org does not like emails directly from gmail , it seems =)
>
> ( sorry for sending this 3 time now )
>
> The following patch should fix the build failure.
>
> diff --git a/drivers/net/sis190.c b/drivers/net/sis190.c
> index b570402..e48e4ad 100644
> --- a/drivers/net/sis190.c
> +++ b/drivers/net/sis190.c
> @@ -326,7 +326,7 @@ static const struct {
> { "SiS 191 PCI Gigabit Ethernet adapter" },
> };
>
> -static struct pci_device_id sis190_pci_tbl[] __devinitdata = {
> +static const struct pci_device_id sis190_pci_tbl[] __devinitdata = {
> { PCI_DEVICE(PCI_VENDOR_ID_SI, 0x0190), 0, 0, 0 },
> { PCI_DEVICE(PCI_VENDOR_ID_SI, 0x0191), 0, 0, 1 },
> { 0, },
>
>
> Gabriel

Hi Gabriel,

Thanks, the patch fixes the build failure.


--
Thanks & Regards,
Kamalesh Babulal,
Linux Technology Center,
IBM, ISTL.


\
 
 \ /
  Last update: 2008-01-30 09:11    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site