[lkml]   [2008]   [Jan]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH] teach about list_for_each
On Thu, Jan 03, 2008 at 11:10:58AM +0000, Andy Whitcroft wrote:
> We have had some stabs at changing this, but no consensus was reached on
> whether it was a "for" or a "function". My memory is of there being
> slightly more "without a space" tenders than the other and so it has not
> been changed. This thread also seems so far to have not really
> generated a concensus. So I would tend to leave things as they are.
> A third option might be to accept either on *for_each* constructs.
> That might tend to lead to divergance. Difficult. However, also see my
> later comments on "style guide".

Pretty much all core code uses list_for_each_entry( so new code should
follow that example.

 \ /
  Last update: 2008-01-03 13:29    [W:0.088 / U:1.276 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site