lkml.org 
[lkml]   [2008]   [Jan]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [patch 1/3] move WARN_ON() out of line
Matt Mackall wrote:
>
> I hate the do_foo naming scheme (how about __warn_on?), but otherwise:
>
> Acked-by: Matt Mackall <mpm@selenic.com>

after I moved it around based on Olof's work, I've now ended up with

warn_on_slowpath()

>
>> + printk(KERN_WARNING "WARNING: at %s:%d %s()\n",
>> + __FILE__, __LINE__, __FUNCTION__);
>> + dump_stack();
>
> While we're here, I'll mention that dump_stack probably ought to take a
> severity level argument.

125 files changed, 202 insertions(+), 199 deletions(-)
just to get the api change done.
I can hear akpm cringe from here...

>



\
 
 \ /
  Last update: 2008-01-03 22:11    [from the cache]
©2003-2011 Jasper Spaans