lkml.org 
[lkml]   [2008]   [Jan]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: kexec refuses to boot latest -mm
    On Mon, Dec 31, 2007 at 10:08:43AM -0500, Vivek Goyal wrote:
    > On Sat, Dec 29, 2007 at 11:11:13AM +0530, Dhaval Giani wrote:
    > > On Fri, Dec 28, 2007 at 09:27:39AM -0500, Vivek Goyal wrote:
    > > > On Fri, Dec 28, 2007 at 06:15:32PM +0530, Dhaval Giani wrote:
    > > > > Hi Vivek,
    > > > >
    > > > > I can't seem to get the latest -mm (2.6.24-rc6-mm1) to boot with
    > > > > kexec. It just gets stuck at "Starting new kernel".
    > > > >
    > > > > It does boot normally when booted as the first kernel.
    > > > >
    > > > > Any hints debugging? (x86 architecture)
    > > >
    > > > I generally try few things.
    > > >
    > > > - Specify earlyprintk= parameter for second kernel and see if control
    > > > is reaching to second kernel.
    > > >
    > > > - Otherwise specify --console-serial parameter on "kexec -l" commandline
    > > > and it should display a message "I am in purgatory" on serial console.
    > > > This will just mean that control has reached at least till purgatory.
    > > >
    > >
    > > Ok, so it reaches till here. I get "I'm in purgatory" on the console.
    >
    > One more thing. Is 2.6.24-rc6 working properly?
    >

    2.6.24-rc5 boots, so does 2.6.24-rc5-mm1. 2.6.24-rc6 does not boot, nor
    does 2.6.24-rc6-mm1. Its a regression.

    i will add more outbs and respond back and try a bisect if that does not
    help.

    Thanks
    --
    regards,
    Dhaval


    \
     
     \ /
      Last update: 2008-01-03 20:55    [W:0.064 / U:2.480 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site