[lkml]   [2007]   [Sep]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: Linux, pata_ali issue

    From my point, sorry for thread hijacking, but I did not have
    the upper node anymore.

    So, here is something that I think should go into the next 2.6.22.
    A proper fix is already in 2.6.23-git-du-jour.

    In function ■ali_init_chipset■:

    warning: ■rev■ is used uninitialized in this function

    Yes, it is indeed used uninitialized, and that is dangerous,
    given that I do have a chipset that uses pata_ali.ko and
    currently runs a 'broken' has not exploded yet, though.

    I could not backport and create a patch because struct pci_dev
    does not have the ->revision field in 2.6.22 yet. Ideas?
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2007-09-25 19:05    [W:0.018 / U:25.992 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site