lkml.org 
[lkml]   [2007]   [Sep]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 2/4] [-mm patch] Add nodemask_t's size and NR_FREE_PAGES's value to vmcoreinfo_data.

Hi David,

David Rientjes wrote:
> On Fri, 14 Sep 2007, Ken'ichi Ohmichi wrote:
>
>> diff -rpuN a/include/linux/kexec.h b/include/linux/kexec.h
>> --- a/include/linux/kexec.h 2007-09-10 23:28:42.000000000 +0900
>> +++ b/include/linux/kexec.h 2007-09-10 23:29:52.000000000 +0900
>> @@ -132,11 +132,16 @@ unsigned long paddr_vmcoreinfo_note(void
>> #define SIZE(name) \
>> vmcoreinfo_append_str("SIZE(%s)=%lu\n", #name, \
>> (unsigned long)sizeof(struct name))
>> +#define TYPEDEF_SIZE(name) \
>> + vmcoreinfo_append_str("SIZE(%s)=%lu\n", #name, \
>> + (unsigned long)sizeof(name))
>> #define OFFSET(name, field) \
>> vmcoreinfo_append_str("OFFSET(%s.%s)=%lu\n", #name, #field, \
>> (unsigned long)&(((struct name *)0)->field))
>> #define LENGTH(name, value) \
>> vmcoreinfo_append_str("LENGTH(%s)=%lu\n", #name, (unsigned long)value)
>> +#define NUMBER(name) \
>> + vmcoreinfo_append_str("NUMBER(%s)=%ld\n", #name, (long)name)
>> #define CONFIG(name) \
>> vmcoreinfo_append_str("CONFIG_%s=y\n", #name)
>>
>
> The #define SIZE() should be renamed STRUCT_SIZE() since it's always returning the size of the struct with a given name. This would allow TYPEDEF_SIZE() to simply become SIZE() since it need not be used exclusively for typedefs.

Thank you for the comment.
That sounds good, I'll post a new patch including it.


Thanks
Ken'ichi Ohmichi
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2007-09-20 07:19    [from the cache]
©2003-2011 Jasper Spaans. Advertise on this site