[lkml]   [2007]   [Aug]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: [PATCH 14/25] sysfs: Don't use lookup_one_len_kern
    Eric W. Biederman wrote:
    >> right? I don't think we need to duplicate the code here. Or is it
    >> needed for later multi-sb thing?
    > Right. We can do that as well. In practice in working code
    > there is no real difference.
    > There is a little extra uniformity in rolling it ourselves, but
    > not enough to worry about either way.
    > In the review/debug etc cycle it just wound up being a lot easier
    > to roll the code myself.
    > By the time we get to lookup_one_len_kern it is almost impenetrable
    > code in namei.c where sysfs_add_dentry tends is easier to comprehend,
    > and to modify for debugging.

    Yeap, agreed. I agreed with this one too in the comment for the next
    patch. I guess I should have wrote here too. Sorry about the trouble.


    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2007-08-08 17:39    [W:0.021 / U:0.184 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site