lkml.org 
[lkml]   [2007]   [Aug]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: Problems with USB disk
Date
On Wednesday 08 August 2007 13:48:29 you wrote:
> On Tuesday 07 August 2007 23:18, Greg KH wrote:
> > On Tue, Aug 07, 2007 at 10:26:15PM +0200, Niels wrote:
> >> Hi,
> >>
> >> I'm having problems with a new 500 GB USB disk. It works, but sometimes
> >> I get these in dmesg:
> >>
> >>
> >> usb 1-3: reset high speed USB device using ehci_hcd and address 2
> >> usb 5-1: USB disconnect, address 2
> >> drivers/usb/class/usblp.c: usblp0: removed
> >> sd 0:0:0:0: Device not ready: <6>: Sense Key : 0x2 [current]
> >>
> >> : ASC=0x4 ASCQ=0x2
> >>
> >> end_request: I/O error, dev sda, sector 254148215
> >> sd 0:0:0:0: Device not ready: <6>: Sense Key : 0x2 [current]
> >>
> >> : ASC=0x4 ASCQ=0x2
> >>
> >> end_request: I/O error, dev sda, sector 252434023
> >> EXT3-fs error (device sda1): ext3_find_entry: reading directory
> >> #15761836 offset 0
> >>
> >>
> >> There's also a printer connected. This is on a pci/usb2 card. When the
> >> above happens, I get I/O errors. When I mount the drive next, there are
> >> errors and often missing files. Quite annoying!
> >>
> >> Kernel is 2.6.21
> >>
> >> What's going on?
> >
> > You have a low voltage issue, or a bad cable. The device is
> > electronically disconnecting itself. Try using a externally-powered
> > hub, or a new cable.

I am seeing a similar problem with 2.6.22 and 2.6.23-* kernels with my 60G
iPod Video, works fine with 2.6.18 kernel though.

Rehards,
ismail



--
Perfect is the enemy of good
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2007-08-08 12:59    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site