lkml.org 
[lkml]   [2007]   [Aug]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: 2.6.23-rc1 regression: hwmon/w83627ehf: wrong fan speed
Hi Stefan:

* Stefan Richter <stefanr@s5r6.in-berlin.de> [2007-08-05 13:20:48 +0200]:
> Now that I booted from 2.6.22-rc5 to 2.6.23-rc2 I noticed that ksensors
> displayed 1/16 of the actual speed of the CPU fan (correct is ca. 1400
> RPM under light load) and 0 for the case fan (correct is ca. 480 RPM
> under light load).
>
> I reverted patch
> hwmon/w83627ehf: No need to initialize fan_min
> and the behaviour changed as follows: ksensors displays the correct CPU
> fan speed when loaded for the first time after the w83627ehf was loaded,
> then drops to 1/16th the next time it refreshes the display. (I
> configured 30s update interval in ksensors.) But the case fan's speed
> is now correctly displayed all the time. Ksensors' fan speed
> multipliers are configured as 1.
>
> I then also reverted
> hwmon/w83627ehf: Be quiet when no chip is found
> hwmon/w83627ehf: Export the thermal sensor types
> hwmon/w83627ehf: Enable VBAT monitoring
> hwmon/w83627ehf: Add support for the VID inputs
> hwmon/w83627ehf: Fix timing issues
> hwmon/w83627ehf: Add error messages for two error cases
> one after another but it didn't change anything. More surprisingly, if
> I put all patches including "No need to initialize fan_min" back in, the
> behaviour remains like after referting that single patch, i.e. wrong CPU
> fan speed after first display update, correct case fan speed. I didn't
> reboot between tests though, I only unloaded and reloaded w83627ehf.

It's not always sufficient to just reload the driver, especially when it's an
initialization problem as yours seems to be. So what you're seeing there is
not too surprising.

> I wasn't able to revert
> hwmon/w83627ehf: Convert to a platform driver
> to something that compiles but I didn't try very hard.

That's because a later patch removes the i2c-isa support on which this driver
depends, prior to this patch. If you can use git to back up, that would be
easier.

That said, I doubt the "Convert to a platform driver" is the problem. It's
more likely the patch before that:

hwmon/w83627ehf: Preserve speed reading when changing fan min

I'll reexamine the patch series here. If you have time, it would help if you
could do a git bisect. Use this command:

$ git bisect start v2.6.23-rc2 v2.6.22-rc5 drivers/hwmon/w83627ehf.c

Doing it this way will force you to reboot between tests; I think we would
need that anyway.

> Kernel messages when I load the drivers:
> w83627ehf: unsupported chip ID: 0xffff
> w83627ehf: Found W83627EHG chip at 0x290
> The former message is normally suppressed by patch "Be quiet when no
> chip is found". Mainboard is an MSI 945GT Speedster-A4R, userland is
> Gentoo's lm_sensors-2.10.1 and ksensors-0.7.3.
>
> Booting back into 2.6.22-rc5 (which seems identical with 2.6.22 as far
> as w83627ehf is concerned) brings back the correct fan speeds.

Regards,

--
Mark M. Hoffman
mhoffman@lightlink.com

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2007-08-05 16:03    [from the cache]
©2003-2011 Jasper Spaans. Advertise on this site