[lkml]   [2007]   [Aug]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: [07/36] Use page_cache_xxx in mm/filemap_xip.c
    Christoph Hellwig wrote:
    > On Tue, Aug 28, 2007 at 09:49:38PM +0200, J??rn Engel wrote:
    >>On Tue, 28 August 2007 12:05:58 -0700, wrote:
    >>>- index = *ppos >> PAGE_CACHE_SHIFT;
    >>>- offset = *ppos & ~PAGE_CACHE_MASK;
    >>>+ index = page_cache_index(mapping, *ppos);
    >>>+ offset = page_cache_offset(mapping, *ppos);
    >>Part of me feels inclined to marge this patch now because it makes the
    >>code more readable, even if page_cache_index() is implemented as
    >>#define page_cache_index(mapping, pos) ((pos) >> PAGE_CACHE_SHIFT)
    >>I know there is little use in yet another global search'n'replace
    >>wankfest and Andrew might wash my mouth just for mentioning it. Still,
    >>hard to dislike this part of your patch.
    > Yes, I I suggested that before. Andrew seems to somehow hate this
    > patchset, but even if we don;'t get it in the lowercase macros are much
    > much better then the current PAGE_CACHE_* confusion.

    I don't mind the change either. The open coded macros are very
    recognisable, but it isn't hard to have a typo and get one
    slightly wrong.

    If it goes upstream now it wouldn't have the mapping argument
    though, would it? Or the need to replace PAGE_CACHE_SIZE I guess.

    SUSE Labs, Novell Inc.
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2007-08-29 01:53    [W:5.079 / U:0.016 seconds]
    ©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site