lkml.org 
[lkml]   [2007]   [May]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject2.6.21-mm1: DRM does kmalloc(0) sometimes?
Is this a sign of bug? The box is functioning OK, despite

WARN_ON_ONCE(size == 0);
-------------------------------------------------------------
CONFIG_DRM=y
CONFIG_DRM_RADEON=y
X.org 7.1.1 as shipped with Gentoo
VGA compatible controller: ATI Technologies Inc RV350 AP [Radeon 9600]
-------------------------------------------------------------
...
agpgart: Found an AGP 3.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V3 device at 0000:00:00.0 into 4x mode
agpgart: Putting AGP V3 device at 0000:01:00.0 into 4x mode
eth0: link up, 100Mbps, full-duplex, lpa 0x41E1
eth1: link up, 100Mbps, full-duplex, lpa 0x45E1
eth1: link up, 100Mbps, full-duplex, lpa 0x45E1
[drm] Setting GART location based on new memory map
[drm] Loading R300 Microcode
[drm] writeback test succeeded in 1 usecs
BUG: at include/linux/slub_def.h:88 kmalloc_index()
[<c0147ed1>] get_slab+0x43/0x1c6
[<c01480b3>] __kmalloc+0xc/0x2b
[<c027c1e6>] drm_rmdraw+0x0/0x251
[<c027c30f>] drm_rmdraw+0x129/0x251
[<c027c1e6>] drm_rmdraw+0x0/0x251
[<c027ce2f>] drm_ioctl+0x152/0x197
[<c0153b0c>] do_ioctl+0x4c/0x64
[<c0153d61>] vfs_ioctl+0x23d/0x250
[<c01025e2>] sysenter_past_esp+0x8f/0x99
[<c0153da7>] sys_ioctl+0x33/0x4c
[<c01025b2>] sysenter_past_esp+0x5f/0x99
=======================
agpgart: Found an AGP 3.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V3 device at 0000:00:00.0 into 4x mode
agpgart: Putting AGP V3 device at 0000:01:00.0 into 4x mode
[drm] Setting GART location based on new memory map
[drm] Loading R300 Microcode
[drm] writeback test succeeded in 1 usecs
agpgart: Found an AGP 3.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V3 device at 0000:00:00.0 into 4x mode
agpgart: Putting AGP V3 device at 0000:01:00.0 into 4x mode
[drm] Loading R300 Microcode
agpgart: Found an AGP 3.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V3 device at 0000:00:00.0 into 4x mode
agpgart: Putting AGP V3 device at 0000:01:00.0 into 4x mode
[drm] Loading R300 Microcode
agpgart: Found an AGP 3.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V3 device at 0000:00:00.0 into 4x mode
agpgart: Putting AGP V3 device at 0000:01:00.0 into 4x mode
[drm] Loading R300 Microcode
agpgart: Found an AGP 3.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V3 device at 0000:00:00.0 into 4x mode
agpgart: Putting AGP V3 device at 0000:01:00.0 into 4x mode
[drm] Loading R300 Microcode
agpgart: Found an AGP 3.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V3 device at 0000:00:00.0 into 4x mode
agpgart: Putting AGP V3 device at 0000:01:00.0 into 4x mode
[drm] Loading R300 Microcode
Clocksource tsc unstable (delta = 104013683 ns)
Time: pit clocksource has been installed.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2007-05-06 21:03    [from the cache]
©2003-2011 Jasper Spaans