[lkml]   [2007]   [May]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 2/2] [condingstyle] Add chapter on tests
Stefan Richter wrote:
> Auke Kok wrote:
>> +If you give your variables and pointers good names, there is never a need
>> +to compare the value stored in that variable to NULL or true/false, so
>> +omit all that and keep it short.
> I agree with this in principle. But do we have to standardize it?

yes, I think so. Not only does it remove useless fluff but it forces you to pick
your function and variable names decently. It really doesn't hurt to mention it
especially when you see how many drivers have copied bad style over without
knowing better. Now we can refer them to the CodingStyle doc right away.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2007-05-25 19:43    [W:0.125 / U:0.900 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site