[lkml]   [2007]   [Apr]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: init's children list is long and slows reaping children.
Ingo Molnar wrote:
> * Linus Torvalds <> wrote:
>> On Fri, 6 Apr 2007, Davide Libenzi wrote:
>>>> or lets just face it and name it what it is: process_struct ;-)
>>> That'd be fine too! Wonder if Linus would swallow a rename patch like
>>> that...
>> I don't really see the point. It's not even *true*. A "process"
>> includes more than the shared signal-handling - it would include files
>> and fs etc too.
>> So it's actually *more* correct to call it the shared signal state
>> than it would be to call it "process" state.
> we could call it "structure for everything that we know to be ugly about
> POSIX process semantics" ;-) The rest, like files and fs we've
> abstracted out already.
> Ingo
So are you voting for ugly_struct? ;-)

I do think this is still waiting for a more descriptive name, like
proc_misc_struct or some such. Kernel code should be treated as
literature, intended to be both read and readable.

Bill Davidsen <>
"We have more to fear from the bungling of the incompetent than from
the machinations of the wicked." - from Slashdot

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2007-04-09 20:19    [W:0.155 / U:20.412 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site