lkml.org 
[lkml]   [2007]   [Mar]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    From
    Subject2.6.21-rc3: /proc broken
    Date
    On Friday 09 March 2007 01:52, Con Kolivas wrote:
    > On Thursday 08 March 2007 15:19, Andrew Morton wrote:
    > > ftp://ftp.kernel.org/pub/linux/kernel/people/akpm/patches/2.6/2.6.21-rc3/
    > >2. 6.21-rc3-mm2/
    > >
    > > - This is the same as 2.6.21-rc3-mm1, except Con's CPU scheduler changes
    > > were dropped.

    > So on qemu I can reproduce the oops you're getting with your config (make
    > oldconfig all default on top of your config), but I'm getting other
    > wonderful related problems too on rc3-mm2. On qemu -mm1 boots mostly
    > without error and then crashes nicely when I type 'ps' with a long pause
    > for about twenty seconds and then a combination of soft lockups, bitmap
    > errors, and eventually hits the BUG_ON I put in bitmap_error(). However,
    > -mm2 also vomits on typing 'ps'.
    >
    > It pauses and then spits out (fun lines selected from ps output):
    >
    > 7 ? serial8250: too much work for irq4
    > 00:00:00 watchdog/1
    > 88 ? 00:00:0serial8250: too much work for irq4
    > 0 cqueue/1
    > 137 ? 00:00serial8250: too much work for irq4
    >
    > :00 aio/0
    >
    > Checking a few /proc files I see that "serial83250" info littered
    > throughout /proc/stat as well. -mm2 does not oops but the proc output is
    > variously corrupted.
    >
    > Interestingly if I don't type 'ps' in the -mm1 qemu it runs fine with no
    > sign of a bug... In summary, here I can only reproduce your big fat oops by
    > it being triggered by some corruption elsewhere on this config related to
    > /proc breakage that I haven't managed to track down. I checked the
    > broken-out patches to see which touched /proc and it was oh, most of them.
    > I tried on rc3 and had the same thing happen. I haven't tried rc3 without
    > rsdl (your config takes too darn long to build!).

    /proc appears broken on vanilla -rc3 as well.

    I did make oldconfig from http://userweb.kernel.org/~akpm/ck/config.txt and
    chose all the defaults. Then building your fat config with -rc3, 'ps' hangs
    on qemu for almost 30 seconds and then at last produces a broken output

    PID TTY TIME CMD
    1 ? 00:00:00 init
    2 ? 00:00:00 migration/0
    3 ? 00:00:00 ksoftirqd/0
    4 ? 00:00:00 watchdog/0
    5 ? 00:00:00 migration/1
    6 ? 00:00:00 ksoftirqd/1
    7 ? serial8250: too much work for irq4
    00:00:00 watchdog/1
    8 ? 00:00:00 events/0
    9 ? 00:00:00 events/1
    10 ? 00:00:00 khelper
    11 ? 00:00:00 kthread
    52 ? 00:00:00 kblockd/0
    53 ? 00:00:00 kblockd/1
    54 ? 00:00:00 kacpid
    87 ? 00:00:00 cqueue/0
    88 ? 00:00:00 cqueue/1
    89 ? 00:00:00 ata/0
    90 ? 00:00:00 ata/1
    91 ? 00:00:00 ata_aux
    92 ? 00:00:00 ksuspend_usbd
    95 ? 00:00:00 khubd
    97 ? 00:00:00 kseriod
    133 ? 00:00:00 pdflush
    134 ? 00:00:00 pdflush
    135 ? 00:00:00 kserial8250: too much work for irq4
    swapd0
    136 ? 00:00:00 aio/0
    137 ? 00:00:00 aio/1
    287 ? 00:00:00 kpsmoused
    311 ? 00:00:00 sh
    312 ? 00:00:00 ps

    It's random where this happens too. Sometimes it goes away, other times it's
    different tasks, and it happens to /proc/stat too

    --
    -ck
    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2007-03-08 22:59    [W:0.023 / U:120.380 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site