lkml.org 
[lkml]   [2007]   [Mar]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRE: [PATCH 2/3] aio: fix oops because of extra IO control block freeing.
On Mon, 5 Mar 2007, Ananiev, Leonid I wrote:

>
>
> >Where is kiocbSetPgBusy() defined,
> It is defined in include/linux/aio.h (introduced in [PATCH 1/3])
> > and where in the documentation is it explained?
> I will add a comment for kiocbSetPgBusy()in aio.h.
>
> > For that matter, what is the reason for changing the return value at
> all?
> EIORETRY is not IO return value at all. It is processing stage.
> It conflicts with IO return value. That is why a flag in iocb is used.
> It should be noted that loop but not EIOCBRETRY was used for vector IO
> (mm/filemap.c)

Okay. But I don't like the name. "kiocbSetPgBusy" might be meaningful to
people who understand fs/aio.c, but it isn't meaningful to other people.

Could you add this to aio.h:

#define mark_iocb_not_complete(iocb) kiocbSetPgBusy(iocb)

That would be a lot easier to understand.

Alan Stern


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2007-03-05 22:27    [W:0.088 / U:0.420 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site