lkml.org 
[lkml]   [2007]   [Mar]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: BUG: soft lockup during suspend
Takashi Iwai wrote:
> At Tue, 20 Mar 2007 17:08:48 +0100,
> I wrote:
>> At Tue, 20 Mar 2007 12:05:07 -0400,
>> Chuck Ebbert wrote:
>>> Takashi Iwai wrote:
>>>> X60/T60 is known to be often broken regarding the communication
>>>> between the controller and the codec chip. When this kind of thing
>>>> happens, the driver tries to switch to a single-shot I/O without using
>>>> ring-buffers and IRQs, and even in such a mode, the communication gets
>>>> broken. FWIW, it doesn't happen on other machines with HD-audio, so
>>>> it's fairly specific to X60/T60. No idea why.
>>> What about Acer Aspire 5102?
>>>
>>> http://lkml.org/lkml/2006/12/3/9
>> This is a different problem.
>> A known workaround is to provide probe_mask=1 module option.
>
> BTW, does this happen on the latest linus git tree? (rc4 may work,
> though)
>
> If yes, could you try the patch below?
>

I can't easily test 2.6.21-rc, but "probe_mask=1" works on 2.6.20.4, which spews
errors without that. Should I try your patch on 2.6.20?
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2007-03-20 17:37    [W:0.052 / U:0.224 seconds]
©2003-2014 Jasper Spaans. Advertise on this site