lkml.org 
[lkml]   [2007]   [Mar]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRE: [git patches] libata fixes


    On Sun, 11 Mar 2007, Paul Rolland wrote:
    >
    > My machine is having two problems : the one you are describing above,
    > which is due to a SIL controler being connected to one port of the ICH7
    > (at least, it seems to), and probing it goes timeout, but nothing is
    > connected on it.

    Ok, so that's just a message irritation, not actually bothersome
    otherwise?

    > The second problem is a Jmicron363 controler that is failing to detect
    > the DVD-RW that is connected, unless I use the irqpoll option as Tejun has
    > suggested.

    .. and this one has never worked without irqpoll?

    > But, as you suggest it, I'm adding pci=nomsi to the command line....
    > rebooting... no change for this part of the problem.
    >
    > OK, the /proc/interrupt for this config, and the dmesg attached.
    >
    > 3 [23:22] rol@riri:~> cat /proc/interrupts
    > CPU0 CPU1
    > 0: 297549 0 IO-APIC-edge timer
    > 1: 7 0 IO-APIC-edge i8042
    > 4: 13 0 IO-APIC-edge serial
    > 6: 5 0 IO-APIC-edge floppy
    > 8: 1 0 IO-APIC-edge rtc
    > 9: 0 0 IO-APIC-fasteoi acpi
    > 12: 126 0 IO-APIC-edge i8042
    > 14: 8313 0 IO-APIC-edge libata
    > 15: 0 0 IO-APIC-edge libata
    > 16: 0 0 IO-APIC-fasteoi eth1, libata

    So it's the irq16 one that is the Jmicron controller and just isn't
    getting any interrupts?

    Since all the other interrupts work (and MSI worked for other
    controllers), I don't think it's interrupt-routing related. Especially as
    MSI shouldn't even care about things like that.

    And since it all works when "irqpoll" is used, that implies that the
    *only* thing that is broken is literally irq delivery.

    Is there possibly some jmicron-specific "enable interrupts" bit?

    > PS : I'd like to try 2.6.21-rc3, but it seems that this is breaking my
    > config : disk naming is no more the same, and I end up with a panic
    > Warning: unable to open an initial console
    > though i've been compiling with the same .config I was using for 2.6.21-rc2

    Gaah. Can you get a log through serial console or netconsole to see what
    changed?

    Linus
    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2007-03-12 02:03    [W:0.056 / U:92.856 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site