[lkml]   [2007]   [Feb]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectA CodingStyle suggestion
Hi all,

In CodingStyle Chapter 16 "Function return value and names", why not
adding a comment about the favorable community way of checking the return
value. ie:

ret = do_method();
if (ret) {
/* deal with error */
and not other ways like:

if (do_method()) or if ((ret = do_method()) > value) ...
A patch is ready if the replies are positive.

Ahmed S. Darwish
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2007-02-03 23:01    [from the cache]
©2003-2014 Jasper Spaans. hosted at Digital Ocean