lkml.org 
[lkml]   [2007]   [Feb]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: 2.6.20: libata PATA ATAPI CDROM weirdness on ALI
Date
Brandon Low wrote:

> I'm having some weirdness during boot with my optical drives on 2.6.20.
>
> ata2.00: ATAPI, max UDMA/33
> ata2.01: ATAPI, max UDMA/33
> ata2.00: qc timeout (cmd 0xef)
> ata2.00: failed to set xfermode (err_mask=0x4)
> ata2.00: limiting speed to UDMA/25
> ata2: failed to recover some devices, retrying in 5 secs
> ata2.00: configured for UDMA/25
> ata2.01: configured for UDMA/33
>
> the 4 lines starting with qc timeout _would_ repeat with lower speeds
> until the drive was finally disabled and then do the same for 2.01,
> except that on this particular attempt, I had the thought to eject both
> optical drives while it sat there. Boot then proceeded normally and the
> drives appear to work.
>
> Intuitively this seems to indicate that the drives aren't being sent
> some kind of wake-up call before their transfer modes are set.
>
> The motherboard is an ASRock 939 Dual SATA II.
>

In my case of relatively old ALi chipset CD-ROM was never detected if DMA is
allowed. Unfortunately this remained mystery for quite some time. Legacy
IDE drivers are working just fine; it is only pata_ali that failes :(

See e.g. http://marc.theaimsgroup.com/?l=linux-kernel&m=116500554505311&w=2
(2.6.19: ALi M5229 - CD-ROM not found with pata_ali)

if you have any idea how to debug it ...

-andrey


> Let me know if there is any more information that I can provide.
>
> Thanks,
>
> Brandon Low


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2007-02-18 07:01    [from the cache]
©2003-2011 Jasper Spaans