lkml.org 
[lkml]   [2007]   [Feb]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Coding style RFC: convert "for (i=0;i<ARRAY_SIZE(array);i++)" to "array_for_each(index, array)"
Joe Perches wrote:
> On Tue, 2007-02-13 at 15:19 +1100, Nick Piggin wrote:
>
>>>> #define array_for_each(element, array) \
>>>> for (int __idx = 0; __idx < ARRAY_SIZE((array)); \
>>>> __idx++, (element) = &(array[__idx]))
>>
>>If you really wanted to introduce your loop, then please call it
>>array_for_each_idx, or something to distinguish it.
>
>
> perhaps:
>
> #define array_for_each(element, array) \
> for ((element) = (array); \
> (element) < ((array) + ARRAY_SIZE((array))); \
> (element)++)

If you're going for consistency, then shouldn't this be
array_for_each_entry()?

> #define array_for_each_index(index, array) \
> for ((index) = 0; (index) < ARRAY_SIZE((array)); (index)++)

--
SUSE Labs, Novell Inc.
Send instant messages to your online friends http://au.messenger.yahoo.com

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2007-02-13 08:45    [W:0.336 / U:0.132 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site