[lkml]   [2007]   [Feb]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: [PATCH 5/7] cleanup: Rename cpu_gdt_descr and remove extern declaration from smpboot.c
    Rusty Russell wrote:
    > When I implemented the DECLARE_PER_CPU(var) macros, I was careful that
    > people couldn't use "var" in a non-percpu context, by prepending
    > percpu__. I never considered that this would allow them to overload
    > the same name for a per-cpu and a non-percpu variable.
    > It is only one of many horrors in the i386 boot code, but let's rename
    > the non-perpcu cpu_gdt_descr to early_gdt_descr (not boot_gdt_descr,
    > that's something else...)

    Finally, someone not just noticed, but fixed it! Thank you Rusty. Was
    on my todo list, but never bubbled up.

    Acked-by: Zachary Amsden <>
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2007-02-12 10:19    [W:0.025 / U:34.176 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site