lkml.org 
[lkml]   [2007]   [Dec]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Linux 2.6.24-rc5 x86 architecture no longer Oopses...

* Andrew Morton <akpm@linux-foundation.org> wrote:

> > +/*
> > + * Migration helpers - the proper API is the local_read_flags API.
> > + * Will go away in v2.6.26.
> > + */
> > +#define local_save_flags local_read_flags
> > +#define __local_save_flags __local_read_flags
> > +#define raw_local_save_flags raw_local_read_flags
> > +#define __raw_local_save_flags __raw_local_read_flags
> > +
>
> Looks good. We also have local_irq_save(), raw_local_irq_save() and
> __raw_local_irq_save() which might or might not disable interrupts.
> (Do we really need three flavours of these?)

all disable interrupts. All the raw_ and __ APIs are for internal use
only, they should _not_ be used by anything but directly lockdep related
code.

> I guess that people's understanding of spin_lock_irqsave() (note the
> irqsave versus irq_save inconsistency) is sufficiently good for nobody
> to get tripped up by local_irq_save(). But it's a poor name
> nonetheless.

yeah, but it's the historic name that stems from the old cli() API that
had "global scope". I guess these days people know that irq-disabling is
a CPU-local business, not a global thing? I cannot think of any good
alternative name though.

Ingo


\
 
 \ /
  Last update: 2007-12-21 13:33    [W:0.113 / U:0.248 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site