lkml.org 
[lkml]   [2007]   [Dec]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [lm-sensors] 2.6.24-rc4 hwmon it87 probe fails
From
Date

On Sun, 2007-12-09 at 23:02 -0500, Mike Houston wrote:
> On Mon, 10 Dec 2007 10:31:27 +0800
> Shaohua Li <shaohua.li@intel.com> wrote:
> > This should exist in previous kernel (before we remove acpi
> > motherboard driver) too. Basically it's a broken BIOS. Could below
> > patch work around it?
> >
> > Thanks,
> > Shaohua
> >
> > Index: linux/drivers/pnp/system.c
> > ===================================================================
> > --- linux.orig/drivers/pnp/system.c 2007-12-10
> > 10:17:46.000000000 +0800 +++ linux/drivers/pnp/system.c
>
> Thanks Shaohua, I tested this as well and it appears to have worked
> around the issue for me.
>
> Now, in dmesg, I get:
>
> system 00:01: ioport range 0x290-0x29f has been reserved
> (...)
> system 00:01: ioport range 0x290-0x294 could not be reserved
>
> In /proc/ioports I see:
>
> 0290-029f : pnp 00:01
> 0290-0297 : it87
> 0290-0297 : it87
Unfortunately this can't solve all such issues.

Adam & Bjorn,
Could we just reserve IO ports >= 0x1000 in pnp system driver? The
purpose of the driver is to avoid resource conflict with PCI device, and
PCI device can't user io port < 0x1000.

Thanks,
Shaohua



\
 
 \ /
  Last update: 2007-12-17 03:13    [W:0.098 / U:4.252 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site