lkml.org 
[lkml]   [2007]   [Nov]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    SubjectRe: 2.6.23 git current compile error on UP
    From
    Date
    Le jeudi 08 novembre 2007 à 11:55 -0800, Dave Hansen a écrit :
    > drivers/kvm/kvm_main.c: In function `kvm_flush_remote_tlbs':
    > drivers/kvm/kvm_main.c:220: error: implicit declaration of function `smp_call_function_mask'
    > make[2]: *** [drivers/kvm/kvm_main.o] Error 1
    > make[1]: *** [drivers/kvm] Error 2
    >
    > http://sr71.net/~dave/linux/config-kvm-up
    >
    > Looks like that function calls smp_call_function_mask() which is never
    > defined for UP. Nobody else uses it that way, so I'm not sure what the
    > right fix is. I'm not even sure kvm_flush_remote_tlbs() is safe with
    > its raw_smp_processor_id() use. Is there a reason it can't get
    > preempted?

    Avi has already posted a patch to correct this.

    http://lkml.org/lkml/2007/10/24/95

    Laurent
    [unhandled content-type:application/pgp-signature]
    \
     
     \ /
      Last update: 2007-11-08 21:13    [W:0.024 / U:125.616 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site